2015 多校赛 第三场 1002 (hdu 5317)

Description

Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know maxGCD(F(i),F(j)) (Li<jR)
 

Input

There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries. 
In the next T lines, each line contains L, R which is mentioned above. 

All input items are integers. 
1<= T <= 1000000 
2<=L < R<=1000000 
 

Output

For each query,output the answer in a single line. 
See the sample for more details. 
 

Sample Input

2
2 3
3 5
 

Sample Output

1
1
 
注意到F值不大。直接用筛法预处理出F值。用数组num[i][j]记录前 i 个数中有多少个 j。
然后暴力。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 1000005
int t,l,r,F[maxn],num[maxn][10],cnt[10],ans;
void init(){
    for(int i=2;i<=1000000;i++){
        if(F[i]==0){
            for(int j=i<<1;j<=1000000;j+=i)
                F[j]++;
            F[i]=1;
        }
    }
    for(int i=2;i<=1000000;i++){
        for(int j=1;j<=7;j++){
            num[i][j]=num[i-1][j];
            if(F[i]==j) num[i][j]++;
        }
    }
}
int main(){
    init();
    scanf("%d",&t);
    while(t--){
        ans=1;
        scanf("%d%d",&l,&r);
        for(int i=1;i<=7;i++){
            cnt[i]=num[r][i]-num[l-1][i];
            if(cnt[i]>1) ans=i;
        }
        if(cnt[6]&&cnt[3]) ans=max(ans,3);
        if(cnt[6]&&cnt[2]) ans=max(ans,2);
        if(cnt[4]&&cnt[2]) ans=max(ans,2);
        if(cnt[6]&&cnt[4]) ans=max(ans,2);
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

 
 
 
 
 
posted @ 2015-08-04 20:44  轶辰  阅读(148)  评论(0编辑  收藏  举报