ACM1021:Fibonacci Again

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
 
Sample Input
0
1
2
3
4
5
 
Sample Output
no
no
yes
no
no
no
-------------------------------------------------------------------------------
#include <stdio.h>
#include <string.h>
#define N 1000001
int ans[N];

int main()
{
	int i;
	
	int n;
	memset(ans, 0, sizeof(ans));
	ans[0] = 7 % 3;
	ans[1] = 11 % 3;
	for (i = 2; i <= N; i++)
		ans[i] = (ans[i - 1] + ans[i - 2]) % 3;
	while (scanf("%d", &n) != EOF)
	{
		if (ans[n] == 0)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}

  

posted @ 2019-03-20 19:06  烈焰蔷薇  阅读(179)  评论(0编辑  收藏  举报