ACM1019:Least Common Multiple

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
 
Sample Output
105
10296
-------------------------------------------------------------------------------------------
两个数的乘积等于这两个数的最大公约数与最小公倍数的积。
 
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
int gcd(int a, int b);
int main()
{
	int row, N, ans, b;

	scanf("%d", &row);
	while (row)
	{
		scanf("%d%d", &N, &ans);
		for (int i = 0; i < N - 1; i++)
		{
			scanf("%d", &b);
			//两个数的乘积等于这两个数的最大公约数与最小公倍数的积,先除再乘防止越界。
			ans = ans / gcd(ans, b) * b;
		}
		printf("%d\n", ans);
		row--;
	}
	return 0;
}

int gcd(int a, int b)
{
	return b ? gcd(b, a%b) : a;
}

  

posted @ 2019-03-16 13:02  烈焰蔷薇  阅读(211)  评论(0编辑  收藏  举报