ACM1008:Elevator

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers.
The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move
the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at
each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The
elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the
requests are fulfilled.
 
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case
is not to be processed.
 
Output
Print the total time on a single line for each test case.
 
Sample Input
1 2
3 2 3 1
0
 
Sample Output
17
41
-------------------------------------------------------------------------------------------------------------------------
#define _CRT_SECURE_NO_WARNINGS

/*总时间=上楼时间*楼层+下楼时间*楼层+停靠时间*/

#include <stdio.h>

int main()
{
	int N;
	int i;
	//开始楼层
	int startFloor = 0;
	//停靠楼层
	int stayFloor;
	//上楼时间
	int upTime = 6;
	//停靠时间
	int stayTime = 5;
	//下楼时间
	int downTime = 4;
	//上一站停靠楼层
	int lastFloor;
	int time;

	while (scanf("%d", &N) == 1 && N != 0)
	{
		lastFloor = 0;
		time = 0;

		time += N * stayTime;
		while (N)
		{
			scanf("%d", &stayFloor);
			//判断上楼还是下楼
			if (stayFloor > lastFloor)
			{
				time += (stayFloor - lastFloor) * upTime;
			}
			else
			{
				time += (lastFloor - stayFloor) * downTime;
			}
			lastFloor = stayFloor;
			N--;
		}
		printf("%d\n", time);
	}
	return 0;
}

  

 
posted @ 2019-03-13 19:31  烈焰蔷薇  阅读(184)  评论(0编辑  收藏  举报