mthoutai

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理

/*
Lowest Bit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7775    Accepted Submission(s): 5714


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output
For each A in the input, output a line containing only its lowest bit.
Sample Input
26
88
0

Sample Output
2
8

#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	while(~scanf("%d",&n),n)
	{
		//printf("%d\n",n&(-n));
		printf("%d\n",n^(n&(n-1)));
	}
	return 0;
}


posted on 2017-04-25 21:21  mthoutai  阅读(219)  评论(0编辑  收藏  举报