1132 Cut Integer (20)

Cutting an integer means to cut a K digits long integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 x 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 20). Then N lines follow, each gives an integer Z (10<=Z<=2^31^). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line "Yes" if it is such a number, or "No" if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No
 
 
注意点:有除法运算都应注意除数是否为0, 整数的后半段可能为0, 比如10000, 这种情况要单独讨论
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
int main(){
  int a, n, i;
  cin>>n;
  for(i=0; i<n; i++){
    cin>>a;
    int cnt=0, copy=a;
    while(a){
      cnt++;
      a/=10;
    }
    int div=pow(10, cnt/2);
    int x = copy % div, y = copy/div;
    if(x*y==0) cout<<"No"<<endl;
    else if(copy%(x*y)==0) cout<<"Yes"<<endl;
    else cout<<"No"<<endl;
  }
  return 0;
}

 

posted @ 2018-06-09 21:39  赖兴宇  阅读(114)  评论(0编辑  收藏  举报