coder_new

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理

Description

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:
The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input

The input will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
The Tower of Babylon
#include <iostream> 
using namespace std; 
const int MaxN=90; 

typedef struct 
{ 
    int x,y,z; 
    int area;
}Block_area; 

int cmp(const void* p1,const void* q1)  
{ 
    Block_area *p2=(Block_area*) p1; 
    Block_area *q2=(Block_area*) q1;    
    return p2->area - q2->area; 
} 


void Cal(Block_area block[],int N,int case_n) 
{ 
    int h=0; 
    int block_i_current; 

    qsort(block,N,sizeof block[0],cmp); 

    for(int i=0;i<N;i++) 
    { 
        block_i_current=block[i].z; 
        for(int j=0;j<i;j++) 
        { 
            if(((block[j].x<block[i].x&&block[j].y<block[i].y)||(block[j].y<block[i].x&&block[j].x<block[i].y))) 
            { 
                h=block[j].z+block_i_current; 
                if(h>block[i].z) block[i].z=h; 
            } 
        } 

    } 

    int max_h = 0; 
    for( int i=0;i<N;i++) 
        if(max_h<block[i].z) max_h=block[i].z; 
    cout<<"Case "<<case_n<<": maximum height = "<<max_h<<endl; 
} 

int main() 
{ 
    int a,k,m,n,case_n=0,N; 
    Block_area block_area[MaxN]; 
    while((cin>>a)&&a<=30&&a>0) 
    { 
        case_n++; 
        N=3*a; 

        for(int i=0;i<N;i=i+3) 
        { 
            cin>>k>>m>>n; 
            block_area[i].x=k,block_area[i].y=m,block_area[i].z=n;
            block_area[i].area=k*m; 

            block_area[i+1].x=n,block_area[i+1].y=k,block_area[i+1].z=m;
            block_area[i+1].area=n*k; 

            block_area[i+2].x=m,block_area[i+2].y=n,block_area[i+2].z=k;
            block_area[i+2].area=m*n; 
        } 

        Cal(block_area,N,case_n); 
    } 
    return 0; 
} 

 

posted on 2012-04-24 10:27  coder_new  阅读(442)  评论(0编辑  收藏  举报