1067 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,..., N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (105​​) followed by a permutation sequence of {0, 1, ..., N1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9


注意点:1.a!=0别忘    
    2.k必须放在外面,否则超时!


#include<bits/stdc++.h>
using namespace std;

const int maxn = 100010;

int n;

int pos[maxn];






int main(){
	

	
	
	cin>>n;
	
	int a;
	
	int left=n-1,ans=0;
	
	for(int i=0;i<n;i++){
		cin>>a;
		pos[a]=i;
		
		if(pos[a]==a&&a!=0)//a!=0别忘 
			left--;
	}
	
	
	int k=1; //k必须放在外面,否则超时 
	
	while(left>0){
		if(pos[0]==0){
		
			while(k<n){
				if(pos[k]!=k){
					swap(pos[0],pos[k]);
						ans++;
					break;
				}
				
				k++;
			}
			
			
			
		}else{
			swap(pos[0],pos[pos[0]]);
			left--;
			ans++;		
		}
		
		
		
		
	}
	

		
	
	
	cout<<ans<<endl;
	

}

  

posted @ 2019-07-01 16:19  鸥鹭忘机  阅读(273)  评论(0编辑  收藏  举报