HDU 2095 find your present (2)

Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get 
your special present, a lot of presents now putting on the desk, and only one of them 
will be yours.Each present has a card number on it, and your present's card number will 
be the one that different from all the others, and you can assume that only one number 
appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 
2, 1.so your present will be the one with the card number of 3, because 3 is the number 
that different from all the others.
 
Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. 
Following that, n positive integers will be given in a line, all integers will smaller 
than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the 
input.
 
Output
For each case, output an integer in a line, which is the card number of your present.
 
Sample Input
5
1 1 3 2 2
3
1 2 1
0
 
Sample Output
3
2
Hint
Hint
 
use scanf to avoid Time Limit Exceeded
思路解析:
木有想到用异或,这个方法这的很巧妙啊!!
 
异或运算法则  1. a ^ b = b ^ a
  2. a ^ b ^ c = a ^ (b ^ c) = (a ^ b) ^ c;
  3. d = a ^ b ^ c 可以推出 a = d ^ b ^ c.
  4. a ^ b ^ a = b
 
代码:
#include<stdio.h>
int n;
int a;
int b;
int main()
{
    while(~scanf("%d",&n),n)
    {
        scanf("%d",&b);
        for(int c=1;c<n;c++)
        {
            scanf("%d",&a);
            b^=a;
        }
        printf("%d\n",b);
    }
}

posted on 2011-07-20 17:42  moonlit  阅读(504)  评论(0编辑  收藏  举报

导航