1138. Postorder Traversal (25)(树的遍历,前序中序转后序)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

分析:

一道简单的前序中序转后序,而且只需要知道后序的第一个值,所以可以定义一个变量flag,当post的第一个值已经输出,则flag为true,递归出口处判断flag,可以提前return

ps:

经过测试发现没有flag按照正常前序中序转后序也可以AC,但是我在考场上第一次尝试直接转没有提前退出递归的写法并没有能够AC,而是有一部分运行超时,后来增加了flag才AC。可能pat考试时更为严苛,所以对于准备pat考试的小伙伴,建议如果能够缩小运行时间尽量精益求精

原文链接:https://blog.csdn.net/liuchuo/article/details/79064958

AC题解

柳神的方法太精炼,还是传统方法易懂一些,,,

#include <iostream>
#include <algorithm>
#include <vector>

using namespace std;

struct Node {
    int val;
    Node *left, *right;

    Node(int data) : val(data), left(NULL), right(NULL) {};
};

vector<int> in, pre;
bool flag = 0;

Node *creat(int prel, int prer, int inl, int inr) {
    if (prel > prer)return NULL;
    Node *root = new Node(pre[prel]);
    int k;
    for (k = inl; k <= inr && in[k] != pre[prel]; k++);
    int numleft = k - inl;
    root->left = creat(prel + 1, prel + numleft, inl, k - 1);
    root->right = creat(prel + numleft + 1, prer, k + 1, inr);
    return root;
}

void post(Node *root) {
    if (root == NULL)return;
    post(root->left);
    post(root->right);
    if (flag)return;
    printf("%d", root->val);
    flag = true;
}

int main() {
    int n;
    scanf("%d", &n);
    in.resize(n);
    pre.resize(n);
    for (int i = 0; i < n; i++)scanf("%d", &pre[i]);
    for (int i = 0; i < n; i++)scanf("%d", &in[i]);
    Node *root = creat(0, n - 1, 0, n - 1);
    post(root);
    return 0;
}

18分题解

我感觉我写的跟AC题解并没有什么不同,但是却AC不辽,奇怪,,,

#include <bits/stdc++.h>

using namespace std;
struct node
{
    int data;
    node* lc;
    node* rc;
};
int n;
vector<int> pre,in;
bool flag=false;
node* create(int pl,int pr,int il,int ir)
{
    if(pl>pr) return nullptr;
    node* root=new node;
    root->data=pre[pl];
    int k=il;
    while(k<=ir&&pre[pl]!=in[k]) k++;
    root->lc=create(pl+1,pl+k-pl,il,k-1);
    root->rc=create(pl+k-pl+1,pr,k+1,ir);
    return root;
}
void postOrder(node* root)
{
    if(root==nullptr) return;
    postOrder(root->lc);
    postOrder(root->rc);
    if(flag==true) return;
    printf("%d",root->data);
    flag=true;
}
int main()
{
    #ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    cin>>n;
    pre.resize(n);in.resize(n);
    for(int i=0;i<n;i++)
        scanf("%d",&pre[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&in[i]);
    node* root=create(0,n-1,0,n-1);
    postOrder(root);
    return 0;
}
posted @ 2022-02-25 19:58  勇往直前的力量  阅读(29)  评论(0编辑  收藏  举报