1022 Digital Library (30 分)(map)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

生词

英文 解释
query 查询

题目大意:

模拟数字图书馆的查询功能。会给出n本书的信息,以及m个需要查询的命令,数字标号对应相应的命令,数字编号后面的字符串是查询的搜索词,要求输出这行命令以及输出满足条件的书的id,如果一个都没有找到,输出Not Found

分析:

1、对除了id之外的其他信息都建立一个map<string, set>,把相应的id插入对应搜索词的map的集合里面,形成一个信息对应一个集合,集合里面是复合条件的书的id

2、因为对于输入的关键词(可以重复,算是书本对应的tag标签吧~)没有给定关键词的个数,可以使用while(cin >> s)并且判断c = getchar(),c是否等于\n,如果是再退出循环~

3、建立query,通过传参的形式可以将不同的map名称统一化,先要判断map.find()和m.end()是否相等(或者判断m[str].size()==0?),如果不等再去遍历整个map,输出所有满足条件的id,如果相等就说明不存在这个搜索词对应的id,那么就要输出Not Found~

4、传参一定要用引用,否则最后一组数据可能会超时~

原文链接:https://blog.csdn.net/liuchuo/article/details/52263303

22分题解

失分分析:

本来觉得用一个map就行,后来发现如果title、author、key、pub和year如果有相同的值,那么也会出问题。

举个栗子:

2
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
keywords
test code sort keywords
ZUCS Print2
2012
可以发现第一个的key里的keywords与第二个的author相同,所以查找keywords时两者都会输出,而这样是不对的。

解决方法

分别用不同的map记录即可~

#include <bits/stdc++.h>

using namespace std;

map<string,set<int> > m;
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,M,id;
    string s;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        cin>>id;
        //title
        getchar();getline(cin,s);
        //cout<<"title:"<<s<<endl;
        m[s].insert(id);
        //author
        getline(cin,s);
        //cout<<"author:"<<s<<endl;
        m[s].insert(id);
        //key
        while(cin>>s){
            //cout<<"key:"<<s<<endl;
            m[s].insert(id);
            char c=getchar();
            if(c=='\n') break;
        }
        //pub
        getline(cin,s);
        //cout<<"pub:"<<s<<endl;
        m[s].insert(id);
        //year
        cin>>s;
        //cout<<"year:"<<s<<endl;
        m[s].insert(id);
    }
    scanf("%d",&M);
    for(int i=0;i<M;i++){
        scanf("%d: ",&id);
        getline(cin,s);
        cout<<id<<": "+s<<endl;
        if(m[s].size()==0){
            cout<<s<<endl;
            cout<<"Not Found"<<endl;
            continue;
        }
        set<int>::iterator it;
        for(it=m[s].begin();it!=m[s].end();it++)
            cout<<*it<<endl;
    }
    return 0;
}

正确题解

小技巧:
while(cin>>s){ //cout<<"key:"<<s<<endl; key[s].insert(id); char c=getchar(); if(c=='\n') break; }
多项输入换行结束的判断~

#include <bits/stdc++.h>

using namespace std;

map<string,set<int> > title, author, key, pub, year;
void query(map<string,set<int> > &m,string &str){
    //每一个m[str]相当于一个set<int>
    //柳神这里用的是m.find(str) != m.end()判断
    if(m[str].size()!=0){
        //这里就是遍历set的值
        for(auto it=m[str].begin();it!=m[str].end();it++)
            printf("%07d\n",*it);
    }else printf("Not Found\n");
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,M,id;
    string s;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        cin>>id;
        //title
        getchar();getline(cin,s);
        //cout<<"title:"<<s<<endl;
        title[s].insert(id);
        //author
        getline(cin,s);
        //cout<<"author:"<<s<<endl;
        author[s].insert(id);
        //key
        while(cin>>s){
            //cout<<"key:"<<s<<endl;
            key[s].insert(id);
            char c=getchar();
            if(c=='\n') break;
        }
        //pub
        getline(cin,s);
        //cout<<"pub:"<<s<<endl;
        pub[s].insert(id);
        //year
        cin>>s;
        //cout<<"year:"<<s<<endl;
        year[s].insert(id);
    }
    scanf("%d",&M);
    for(int i=0;i<M;i++){
        scanf("%d: ",&id);
        getline(cin,s);
        cout<<id<<": "+s<<endl;
        if(id==1) query(title,s);
        else if(id==2) query(author,s);
        else if(id==3) query(key,s);
        else if(id==4) query(pub,s);
        else if(id==5) query(year,s);
    }
    return 0;
}

posted @ 2021-11-09 10:35  勇往直前的力量  阅读(37)  评论(0编辑  收藏  举报