1008 Elevator (20 分)(数学问题)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

生词

英文 解释
denote 表示
fulfill 满足

题目大意:

电梯从0层开始向上,给出该电梯依次按顺序停的楼层数,并且已知上升需要6秒/层,下降需要4秒/层,停下来的话需要停5秒,问走完所有需要停的楼层后总共花了多少时间~

分析:

累加计算输出~now表示现在的层数,a表示将要去的层数,当a > now,电梯上升,需要6 * (a - now)秒,当a < now,电梯下降,需要4 * (now - a)秒,每一次需要停5秒,最后输出累加的结果sum~
原文链接:https://blog.csdn.net/liuchuo/article/details/51985798

题解

看成了输入样例的4个数都是电梯层数Orz

#include <bits/stdc++.h>

using namespace std;

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,a,now=0,sum=0;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>a;
        if(a>now){
            sum+=(a-now)*6;
            now=a;
        }
        else if(a<now){
            sum+=(now-a)*4;
            now=a;
        }
    }
    cout<<sum+n*5;;
    return 0;
}
posted @ 2021-11-04 21:46  勇往直前的力量  阅读(107)  评论(0编辑  收藏  举报