1006 Sign In and Sign Out (25 分)(查找元素)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

生词

英文 解释
sign in 签到
sign out 登出
guarantee 保证

题目大意:

给出n个人的id、sign in时间、sign out时间,求最早进来的人和最早出去的人的ID~
原文链接:https://blog.csdn.net/liuchuo/article/details/52102459

题解

#include <bits/stdc++.h>

using namespace std;
struct student
{
    string id,in,out;
    int sin,sout;
};
bool cmp1(student a,student b){
    return a.sin<b.sin;
}
bool cmp2(student a,student b){
    return a.sout>b.sout;
}
int transf(string ss){
    int h=atoi(ss.substr(0,2).c_str());
    int m=atoi(ss.substr(2,2).c_str());
    int s=atoi(ss.substr(5,2).c_str());
    return h*3600+m*60+s;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int k;
    cin>>k;
    vector<student> v(k);
    for(int i=0;i<k;i++){
        cin>>v[i].id>>v[i].in>>v[i].out;
        v[i].sin=transf(v[i].in);
        v[i].sout=transf(v[i].out);
    }
    sort(v.begin(),v.end(),cmp1);
    cout<<v[0].id<<" ";
    sort(v.begin(),v.end(),cmp2);
    cout<<v[0].id;
    return 0;
}

柳神题解

没有对比就没有伤害呜呜,柳神代码就是强!

#include <iostream>
#include <climits>
using namespace std;
int main() {
    int n, minn = INT_MAX, maxn = INT_MIN;
    scanf("%d", &n);
    string unlocked, locked;
    for(int i = 0; i < n; i++) {
        string t;
        cin >> t;
        int h1, m1, s1, h2, m2, s2;
        scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
        int tempIn = h1 * 3600 + m1 * 60 + s1;
        int tempOut = h2 * 3600 + m2 * 60 + s2;
        if (tempIn < minn) {
            minn = tempIn;
            unlocked = t;
        }
        if (tempOut > maxn) {
            maxn = tempOut;
            locked = t;
        }
    }
    cout << unlocked << " " << locked;
    return 0;
}
posted @ 2021-11-04 21:13  勇往直前的力量  阅读(36)  评论(0编辑  收藏  举报