航院 6213 Chinese Zodiac

                                 Chinese Zodiac

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 121    Accepted Submission(s): 90


Problem Description
The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be
2 years. But if the signs of the couple is the same, the answer should be 12 years.
 

Input
The first line of input contains an integerT (1T1000) indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
 

Output
For each test case output an integer in a line.
 

Sample Input
3 ox rooster rooster ox dragon dragon
 

Sample Output
8 4 12
 
题意概括:给出一个女人和一个更年轻的男人两个人的生肖,求两个人之间年龄相差多少年。

解题思路:
1: 将所有的属相存入一个二维数组,并由1~12进行编号
2: 将输入的属相与二维数组中的属相比较,若相同,则将其编号赋给一个变量
3: 将两个变量进行比较,若女人的属相编号小于男人的属相编号,则用男人的属相编号减去女人的属相编号;若女人的属相编号大于男人的属相编号,则用男人的属相编号加上12在减去女人的属相编号;若两人属相相同,则输出12.

错误原因:无错误,一次过。

经验总结:
1: 用strcmp判断两个字符串,若相同时返回0. 此时如果要用if语句进行判断,加上非符号!,即可。

我的AC代码:

#include<stdio.h>
#include<string.h>
char s[13][12] = {"0","rat","ox","tiger","rabbit","dragon","snake","horse","sheep","monkey","rooster","dog","pig"};
int main(void)
{
 char s1[12], s2[12];
 int i, n, m, T;
 scanf("%d", &T);
 while(T--)
 {
  scanf("%s%s", &s1, &s2);
  for(i = 1; i <= 12; i ++)
  {
   if(!strcmp(s1, s[i]))
   {
    n = i;
   }
   if(!strcmp(s2, s[i]))
   {
    m = i;
   }  
  }
  if(n ==m)
  {
   printf("12\n");
  }
  else if (n < m)
  {
   printf("%d\n", m - n);
  }
  else
  {
   printf("%d\n", m + 12 -n);
  }
 }
 return 0;
}
posted @ 2017-10-13 19:42  moonlight987  阅读(118)  评论(0编辑  收藏  举报