Codeforces 713 C Sonya and Problem Wihtout a Legend

Description

Sonya was unable to think of a story for this problem, so here comes the formal description.
You are given the array containing \(n\) positive integers. At one turn you can pick any element and increase or decrease it by \(1\). The goal is the make the array strictly increasing by making the minimum possible number of operations. You are allowed to change elements in any way, they can become negative or equal to \(0\).

Input

The first line of the input contains a single integer \(n (1  \le  n \le 3000)\) — the length of the array.
Next line contains \(n\) integer \(a_{i}(1 \le a_{i} \le  10^{9})\).

Output

Print the minimum number of operation required to make the array strictly increasing.

Sample Input

7
2 1 5 11 5 9 11

Sample Output

9

BZOJ1049 数字序列类似,所有我想到了\(O(N^{3})\)做法,果断TLE。标解懂了些,做法太神了,什么维护中位数,但就是不知道转移怎么会没有后效性。
此处介绍另一种做法。首先也是将单调上升变为单调不降(见BZOJ1049 数字序列)。\(f_{i,j}\)表示前\(i\)个数,最大为\(j\)的合法序列最小代价。转移方程

\[f_{i,j} = min\{f_{i-1,k} \}+\mid A_{i}-j \mid(k \le j) \]

当然\(A\)值域太大,我们可以离散化。代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;

typedef long long ll;
#define inf (1LL<<50)
#define maxn (3010)
int N,cnt; ll f[maxn][maxn],ans = inf,A[maxn],B[maxn];

int main()
{
	freopen("E.in","r",stdin);
	freopen("E.out","w",stdout);
	scanf("%d",&N);
	for (int i = 1;i <= N;++i) scanf("%I64d",A+i),A[i] -= i;
	memcpy(B,A,sizeof(B)); B[N+1] = -inf,B[N+2] = inf;
	sort(B+1,B+N+3); cnt = unique(B+1,B+N+3)-B-1;
	A[0] = -inf; A[N+1] = inf;
	memset(f,0x7,sizeof(f)); f[0][1] = 0;
	for (int i = 1;i <= N+1;++i)
	{
		ll tmp = inf;
		for (int j = 1;j <= cnt;++j)
			tmp = min(tmp,f[i-1][j]),f[i][j] = tmp+abs(A[i]-B[j]);
	}
	for (int i = 1;i <= cnt;++i) ans = min(ans,f[N+1][i]);
	printf("%I64d",ans);
	fclose(stdin); fclose(stdout);
	return 0;
}
posted @   lmxyy  阅读(228)  评论(0编辑  收藏  举报
编辑推荐:
· 敏捷开发:如何高效开每日站会
· 为什么 .NET8线程池 容易引发线程饥饿
· golang自带的死锁检测并非银弹
· 如何做好软件架构师
· 记录一次线上服务OOM排查
阅读排行:
· 欧阳的2024年终总结,迷茫,重生与失业
· 在 .NET 中使用 Tesseract 识别图片文字
· Bolt.new 30秒做了一个网站,还能自动部署,难道要吊打 Cursor?
· 敏捷开发:如何高效开每日站会(Daily Stand-up Meeting)
· C#/.NET/.NET Core技术前沿周刊 | 第 20 期(2025年1.1-1.5)
点击右上角即可分享
微信分享提示