UVA1225DigitCounting(简单哈希表)

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is:
12345678910111213
In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.
Input
The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets. For each test case, there is one single line containing the number N.
Output
For each test case, write sequentially in one line the number of digit 0,1,...9 separated by a space.
Sample Input
2 3 13
Sample Output
0 1 1 1 0 0 0 0 0 0 1 6 2 2 1 1 1 1 1 1

//问题连接https://vj.e949.cn/896ed59b7a237fb98e750c3414895dce?v=1544848571

//问题其实就是求1到n的连续数字序列中1~9出现的次数,这里我选择将数字序列存在一个数组里,然后单个数组元素处理,出现相应的数字的话就让对应哈希表

//下标的元素加一。挺简单的题,代码如下

#include <iostream>
#include <cstring>
#define maxn 10005
using namespace std;
int ans[maxn];
int num[10];
int main() {
    int n,k;
    while(cin>>n){
        while(n--)
        {
    cin>>k;
    for(int i=0;i<10;i++)
    num[i]=0;
    for(int i=1; i<=k; i++)
        ans[i-1]=i;
    for(int j=0; j<k; j++) {
        if(ans[j]<10)
            num[ans[j]]++;
        else {
            int k=ans[j];
            for(; k!=0;) {
                num[k%10]++;
                k/=10;
            }
        }
    }
    for(int i=0; i<=9; i++) {
        if(i==9)
            cout<<num[i]<<endl;
        else cout<<num[i]<<" ";
    }
}
}
return 0;
}

 

posted @ 2018-12-17 23:27  龙刃已准备出鞘  阅读(146)  评论(0编辑  收藏  举报