问题 B: c#计算长方形的面积(继承问题)
题目描述
根据给出的代码,补全缺失的代码,输入两个数字为长方形的长和宽,从而得出长方形的面积。
using System;
namespace InheritanceApplication
{
class Shape
{
public void setWidth(int w)
{
width = w;
}
public void setHeight(int h)
{
height = h;
}
protected int width;
protected int height;
}
/****************/
编写此处代码,并只提交此处代码
/****************/
class RectangleTester
{
static void Main(string[] args)
{
Rectangle Rect = new Rectangle();
int width = int.Parse(Console.ReadLine());
int height =int.Parse(Console.ReadLine());
Rect.setWidth(width);
Rect.setHeight(height);
Console.WriteLine("总面积: {0}", Rect.getArea());
Console.ReadKey();
}
}
}
using System;
namespace InheritanceApplication
{
class Shape
{
public void setWidth(int w)
{
width = w;
}
public void setHeight(int h)
{
height = h;
}
protected int width;
protected int height;
}
/****************/
编写此处代码,并只提交此处代码
/****************/
class RectangleTester
{
static void Main(string[] args)
{
Rectangle Rect = new Rectangle();
int width = int.Parse(Console.ReadLine());
int height =int.Parse(Console.ReadLine());
Rect.setWidth(width);
Rect.setHeight(height);
Console.WriteLine("总面积: {0}", Rect.getArea());
Console.ReadKey();
}
}
}
输入
3 5
输出
15
样例输入
5
7
样例输出
35
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 | using System; namespace InheritanceApplication { class Shape { public void setWidth( int w) { width = w; } public void setHeight( int h) { height = h; } protected int width; protected int height; } class Rectangle:Shape { public int getArea() { return width * height; } } class RectangleTester { static void Main( string [] args) { Rectangle Rect = new Rectangle(); int width = int .Parse(Console.ReadLine()); int height = int .Parse(Console.ReadLine()); Rect.setWidth(width); Rect.setHeight(height); Console.WriteLine( "总面积: {0}" , Rect.getArea()); Console.ReadKey(); } } } |
提交部分
1 2 3 4 5 6 7 | class Rectangle:Shape { public int getArea() { return width * height; } } |
【推荐】还在用 ECharts 开发大屏?试试这款永久免费的开源 BI 工具!
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步