Linear Search

Search I

You are given a sequence of n integers S and a sequence of different q integers T. Write a program which outputs C, the number of integers in T which are also in the set S.

Input

In the first line n is given. In the second line, n integers are given. In the third line q is given. Then, in the fourth line, q integers are given.

Output

Print C in a line.

Constraints

  • n ≤ 10000
  • q ≤ 500
  • 0 ≤ an element in S ≤ 109
  • 0 ≤ an element in T ≤ 109

Sample Input 1

5
1 2 3 4 5
3
3 4 1

Sample Output 1

3

Sample Input 2

3
3 1 2
1
5

Sample Output 2

0

Sample Input 3

5
1 1 2 2 3
2
1 2

Sample Output 3

2

向线性搜索中引入"标记"可以将算法效率提高常数倍, 所谓标记, 就是我们在数组等数据结构中设置一个拥有特殊值地元素, 从而达到简化循环控制等诸多目的.
在线性搜索中, 我们可以把含有目标关键字的数据放在数组末尾, 用作标记
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include <iostream>
using namespace std;
int a[10005], b[505];
int n, q;
 
int search(int *a, int c)
{
    int idx = 0;
    a[n] = c;
    while(a[idx] != a[n])   idx ++;
     
    return idx != n;
}
 
int main()
{
    int sum = 0;
    cin >> n;
    for(int i = 0; i < n; ++ i)
        cin >> a[i];
     
    cin >> q;
    for(int i = 0; i < q; ++ i)
    {
        cin >> b[i];
        if(search(a, b[i])) sum ++;
    }
     
    cout << sum << endl;
     
    return 0;
}

  

posted @   青衫客36  阅读(375)  评论(0编辑  收藏  举报
编辑推荐:
· 智能桌面机器人:用.NET IoT库控制舵机并多方法播放表情
· Linux glibc自带哈希表的用例及性能测试
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
阅读排行:
· 手把手教你在本地部署DeepSeek R1,搭建web-ui ,建议收藏!
· 新年开篇:在本地部署DeepSeek大模型实现联网增强的AI应用
· Janus Pro:DeepSeek 开源革新,多模态 AI 的未来
· 互联网不景气了那就玩玩嵌入式吧,用纯.NET开发并制作一个智能桌面机器人(三):用.NET IoT库
· 【非技术】说说2024年我都干了些啥
历史上的今天:
2018-04-21 Problem D: 小平查密码
2018-04-21 Problem C: 文件---单词首字母大写
2018-04-21 Problem B: 文件操作--文本文件读入
2018-04-21 Problem A: 文件操作--二进制文件读入
点击右上角即可分享
微信分享提示