Doubly Linked List

Doubly Linked List

Your task is to implement a double linked list.

Write a program which performs the following operations:

  • insert x: insert an element with key x into the front of the list.
  • delete x: delete the first element which has the key of x from the list. If there is not such element, you need not do anything.
  • deleteFirst: delete the first element from the list.
  • deleteLast: delete the last element from the list.

Input

The input is given in the following format:

n
command
command
...
commandn 

In the first line, the number of operations n is given. In the following n lines, the above mentioned operations are given in the following format:

  • insert x
  • delete x
  • deleteFirst
  • deleteLast

Output

Print all the element (key) in the list after the given operations. Two consequtive keys should be separated by a single space.

Constraints

  • The number of operations ≤ 2,000,000
  • The number of delete operations ≤ 20
  • 0 ≤ value of a key ≤ 109
  • The number of elements in the list does not exceed 106
  • For a delete, deleteFirst or deleteLast operation, there is at least one element in the list.

Sample Input 1

7
insert 5
insert 2
insert 3
insert 1
delete 3
insert 6
delete 5

Sample Output 1

6 1 2

Sample Input 2

9
insert 5
insert 2
insert 3
insert 1
delete 3
insert 6
delete 5
deleteFirst
deleteLast

Sample Output 2

1

注意: 指令和数字不能同时输入, 比如deleteFirst只有指令没有数字, 数字要在相应的判断条件中输入


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#include <iostream>
#include <list>
#include <cstdio>
using namespace std;
 
int main()
{
    int n, num;
    list<int> l;
    char s[20];
    scanf("%d", &n);
    for(int i = 0; i < n; ++ i)
    {
        scanf("%s", s);
        if(s[0] == 'i')
        {
            scanf("%d", &num);
            l.push_front(num);
        }
        else if(s[6] == 'F')
        {
            l.pop_front();
        }
        else if(s[6] == 'L')
        {
            l.pop_back();
        }
        else if(s[0] == 'd')
        {
            scanf("%d", &num);
            for(list<int>::iterator it = l.begin(); it != l.end(); it ++)
            {
                if(*it == num)
                {
                    l.erase(it);
                    break;
                }
            }
        }
    }
     
    int i = 0;
    for(list<int>::iterator it = l.begin(); it != l.end(); it ++)
    {
        if(i ++)    printf(" ");
        printf("%d", *it);
    }
    printf("\n");
     
     
    return 0;
}

  

posted @   青衫客36  阅读(340)  评论(0编辑  收藏  举报
努力加载评论中...
点击右上角即可分享
微信分享提示