ZOJ4063 Tournament [The 2018 ACM-ICPC Asia Qingdao Regional Contest]

Tournament

Time Limit: 1 Second      Memory Limit: 65536 KB

DreamGrid, the king of Gridland, is making a knight tournament. There are  knights, numbered from 1 to , participating in the tournament. The rules of the tournament are listed as follows:

  • The tournament consists of  rounds. Each round consists of several duels. Each duel happens between exactly two knights.
  • Each knight must participate in exactly one duel during each round.
  • For each pair of knights, there can be at most one duel between them during all the  rounds.
  • Let , and  be four distinct integers. If
    • Knight  fights against knight  during round , and
    • Knight  fights against knight  during round , and
    • Knight  fights against knight  during round ,
    then knight  must fight against knight  during round .

As DreamGrid's general, you are asked to write a program to arrange all the duels in all the  rounds, so that the resulting arrangement satisfies the rules above.

Input

There are multiple test cases. The first line of the input is an integer , indicating the number of test cases. For each test case:

The first and only line contains two integers  and  (), indicating the number of knights participating in the tournament and the number of rounds.

It's guaranteed that neither the sum of  nor the sum of  in all test cases will exceed 5000.

Output

For each test case:

  • If it's possible to make a valid arrangement, output  lines. On the -th line, output  integers  separated by one space, indicating that in the -th round, knight  will fight against knight  for all .

    If there are multiple valid answers, output the lexicographically smallest answer.

    Consider two answers  and , let's denote  as the -th integer on the -th line in answer , and  as the -th integer on the -th line in answer . Answer  is lexicographically smaller than answer , if there exists two integers  () and  (), such that

    • for all  and , and
    • for all , and finally .

     

  • If it's impossible to make a valid arrangement, output "Impossible" (without quotes) in one line.

Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

Sample Input

2
3 1
4 3

Sample Output

Impossible
2 1 4 3
3 4 1 2
4 3 2 1

 找规律打表预处理。

#include <bits/stdc++.h>
using namespace std;
int T;
int n,m;
int a[1100][1100];
int ans[1100],tol;

void cal(){
    a[1][1] = 1;
    for (int i = 2;i <= 1024;i *= 2){
        int k = i >> 1;
        for (int r = 1;r <= k;++r){
            for (int c = 1;c <= k;++c){
                a[r][c+k] = a[r][c] + k;
                a[r+k][c] = a[r][c] + k;
                a[r+k][c+k] = a[r][c];
            }
        }
    }
}

int main(){
    
    cal();
    
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        tol = 0;
        for (int i = 2;i <= n;++i){
            int flag = 0;
            for (int j = 1;j <= n;++j) {
                if (a[i][j] > n) {
                    flag = 1;
                    break;
                }
            }
            if (!flag) ans[tol++] = i;
        }
        if (tol < m) {
            puts("Impossible");continue;
        }
        for (int i = 0;i < m;++i){
            for (int j = 1;j <= n;++j){
                printf("%d%c",a[ans[i]][j]," \n"[j==n]);
            }
        }
    }
    return 0;
} 

 

posted @ 2018-11-05 16:15  mizersy  阅读(623)  评论(0编辑  收藏  举报