HDU 1003 Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2:

7 1 6

思路:最大连续子序列:状态方程:sum[i]=max(sum[i-1]+a[i],a[i]);最后从头到尾扫一边

感言:这是一道一粗心就错的题目,假设你还找不到自己代码的错误。那么试一下下面測试数据:

4 0 0 5 0 5 1 3

4 0 0 -1 0 0 1 1

5 -7 -8 -9 -2 -3 -2 4 4

5 -1 -2 5 -2 8 11 3 5

AC代码:

#include<stdio.h>
int a[100005];
int main()
{
    int maxx,sum,i,cnt,flag,tot,t,ms,me,T;
    scanf("%d",&t);
    cnt=1;
    T=t;
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sum=0;
        maxx=a[0];
        flag=tot=ms=0;
        me=1;
        for(i=0;i<n;i++)
        {
            if(sum<0){
                sum=a[i];
                flag=i;
                tot=i+1;
            }
            else{
                tot++;
                sum+=a[i];
            }
            if(sum>maxx){
                ms=flag;
                me=tot;
                maxx=sum;
            }
        }
        printf("Case %d:\n",cnt++);
        printf("%d %d %d\n",maxx,ms+1,me);
        if(cnt<=T)
            printf("\n");
    }
    return 0;
}

这道题我 WA 3次 PE 1次 ==

posted @ 2016-03-12 08:06  mfrbuaa  阅读(154)  评论(0编辑  收藏  举报