POJ 1798 Truck History

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.


题意:输入1个n,代表有多少组字符数组。每一个数组都仅仅有7个字符,每2个数组不同字符的个数代表这2个字符串的距离(如果为距离)。如今要你构建一棵树,使得所花费的距离最小

思路:用Prim算法处理。

AC代码:

#include<stdio.h>
#include<string.h>
#define MAXN 100000000
int mark[2014],f[2014],n;
char str[2014][8];
int val(int i,int j)    //2个字符串的距离
{
    int sum,k;
    sum=0;
    for(k=0;k<7;k++)
        if(str[i][k]!=str[j][k])
            sum++;
    return sum;
}
void  prim()
{
    int i,j,sum=0,minn,k;
    for(i=0;i<n;i++)        //每一个字符串与0的距离
        f[i]=val(0,i);
    memset(mark,0,sizeof(mark));
    f[0]=0;
    mark[0]=1;              //标记已使用过0
    for(i=0;i<n-1;i++)      //Prim算法的核心,这个东西必需要自己理解!
    {
        minn=MAXN;
        for(j=0;j<n;j++)
        {
            if(!mark[j]&&minn>f[j])
            {
                minn=f[j];
                k=j;
            }
        }
        sum+=minn;
        mark[k]=1;
        for(j=0;j<n;j++)        //换一个顶点
            if(!mark[j]&&f[j]>val(k,j))
                f[j]=val(k,j);
    }
    printf("The highest possible quality is 1/%d.\n",sum);
}
int main()
{
    int i;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        for(i=0;i<n;i++)
            scanf("%s",str[i]);
        prim();
    }
    return 0;
}


posted @ 2014-09-30 09:14  mfrbuaa  阅读(272)  评论(0编辑  收藏  举报