hdoj-1212-Big Number【大数取余&简单题】

Big Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6015 Accepted Submission(s): 4205


Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard?

No, I work it out in 10 minutes, and my program contains less than 25 lines.


Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

Output
For each test case, you have to ouput the result of A mod B.

Sample Input
2 3 12 7 152455856554521 3250

Sample Output
2 5 1521

Author
Ignatius.L

Source

Recommend
Eddy | We have carefully selected several similar problems for you: 1215 1211 1210 1214 1695

#include<stdio.h> 
#include<string.h>
int main(){
	int b;
	char a[1010];
	while(~scanf("%s%d",a,&b)){
		 int len=strlen(a),res=0;
		 for(int i=0;i<len;++i){
		 	res=res*10+a[i]-'0';
		 	if(res>=b) 
		 	res=res%b;
		 }
	     printf("%d\n",res);
	}
	return 0;
}



posted @ 2017-06-22 14:01  mfmdaoyou  阅读(256)  评论(0编辑  收藏  举报