hdu hide handkerchief

hide handkerchief

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
 
Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
 
Output
For each input case, you should only the result that Haha can find the handkerchief or not.
 
Sample Input
3 2
-1 -1
 
Sample Output
YES
 
 
对于题目的理解:
     这个题目可以理解为下面的模型。
     开始处于x的位置,每次隔M个访问一次,问最后能否把原来的N个全部访问。(不妨假设这N个序号是从0到N-1)
     如果我们从开始一共走了K步,那么可以得到现在所处的位置是(x+k*M)%N。可以知道如果访问到某个节点的时候,这个节点在前面已经出现过了,且这N个节点没有全部访问完的时候结果是不可能访问完这N个节点。如果出现节点重复,此时恰好走了N步,那么就输出yes。以上的想法可以简单的画图理解。
    由上述分析可知,如果(x+K*M)%N=x(表示出现重复节点),且K=N时结果是yes,所以化简这个式子有:(K*M)%N=0,那么要找到这个最小的K满足这个式子自然会想到最小公倍数。再进一步想如果N*M是M和N的最小公倍数,那么M和N的最大公约数必然是1。也就有了下面的程序。
#include<iostream>
#include<string>
#include<string.h>
using namespace std;
int gcd(int a, int b)
{
	if (a > b)
	{
		a = a + b;
		b = a - b;
		a = a - b;
	}
	while (a != 0)
	{
		int c = b%a;
		b = a;
		a = c;
	}
	return b;
}
int main()
{
	int n, m;
	while (cin >> n >> m)
	{
		if (n == -1 && m == -1)
			break;
		int temp= gcd(n, m);
		if (temp ==1)
			cout << "YES" << endl;
		else cout << "POOR Haha" << endl;
	}
	return 0;
}

  

posted @ 2016-02-01 14:25  第六天喵王  阅读(388)  评论(0编辑  收藏  举报