HDU - 4709 Herding

Description

Little John is herding his father's cattles. As a lazy boy, he cannot tolerate chasing the cattles all the time to avoid unnecessary omission. Luckily, he notice that there were N trees in the meadow numbered from 1 to N, and calculated their cartesian coordinates (Xi, Yi). To herding his cattles safely, the easiest way is to connect some of the trees (with different numbers, of course) with fences, and the close region they formed would be herding area. Little John wants the area of this region to be as small as possible, and it could not be zero, of course.
 

Input

The first line contains the number of test cases T( T<=25 ). Following lines are the scenarios of each test case.
The first line of each test case contains one integer N( 1<=N<=100 ). The following N lines describe the coordinates of the trees. Each of these lines will contain two float numbers Xi and Yi( -1000<=Xi, Yi<=1000 ) representing the coordinates of the corresponding tree. The coordinates of the trees will not coincide with each other.
 

Output

For each test case, please output one number rounded to 2 digits after the decimal point representing the area of the smallest region. Or output "Impossible"(without quotations), if it do not exists such a region.
 

Sample Input

1 4 -1.00 0.00 0.00 -3.00 2.00 0.00 2.00 2.00
 

Sample Output

2.00
 

Source

2013 ACM/ICPC Asia Regional Online ―― Warmup

思路: 枚举计算

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAXN = 150;
const double INF = 100000000.0;

struct node {
	double x, y;
} point[MAXN];
int n;

double dis(int a, int b) {
	return sqrt((point[a].x-point[b].x)*(point[a].x-point[b].x)+(point[a].y-point[b].y)*(point[a].y-point[b].y));
}

double cal(int a, int b, int c) {
	double A = dis(a, b);
	double B = dis(a, c);
	double C = dis(b, c);
	double p = (A+B+C)/2;
	return sqrt(p*(p-A)*(p-B)*(p-C));
}

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%lf%lf", &point[i].x, &point[i].y);
		double ans = 1e20;
		int flag = 0;
		for (int i = 0; i < n; i++)
			for (int j = i+1; j < n; j++)
				for (int k = j+1; k < n; k++) {
					double tmp = cal(i, j, k);
					if (fabs(tmp) >= 0.01) {
						flag = 1;
						ans = min(ans, tmp);
					}
				}
		if (!flag) 
			printf("Impossible\n");
		else printf("%.2lf\n", ans);
	}
}



posted @ 2014-12-18 21:54  mengfanrong  阅读(252)  评论(0编辑  收藏  举报