[USACO2007OPEN G]Cheapest Palindrome

题目描述

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

输入格式

Line 1: Two space-separated integers: N and M

Line 2: This line contains exactly M characters which constitute the initial ID string

Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

输出格式

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

样例 #1

样例输入 #1

3 4
abcb
a 1000 1100
b 350 700
c 200 800

样例输出 #1

900

提示

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

考虑区间dp。
首先初始情况就是只有一个字符或者没有字符,本身就是回文串,价值为0.
一个串如果最左边的字符\(c_l\)和最右边的字符\(c_r\)相等,那么不影响回文,递归到(l+1,r-1)
那么其他的情况下有两种选择,要不就删掉左边的字符,要不就在右边加一个和左边一样的字符。同样,要不删掉右边的字符,要不就在左边加一个和右边一样的字符。然后又有一位不许计算,递推取最小值即可。

#include<bits/stdc++.h>
#define N 2005
using namespace std;
int n,m,ad[35],de[35],dp[N][N];
char c,s[N];
int main()
{
	memset(dp,0x7f,sizeof(dp));
	scanf("%d%d%s",&n,&m,s+1);
	for(int i=1;i<=m;i++)
		dp[i][i]=dp[i][i-1]=0;
	for(int i=1;i<=n;i++)
	{
		scanf(" %c",&c);
		scanf("%d%d",&ad[c-'a'],&de[c-'a']);
	}
	for(int i=2;i<=m;i++)
	{
		for(int j=1;j+i-1<=m;j++)
		{
			dp[j][j+i-1]=min(dp[j+1][j+i-1]+min(de[s[j]-'a'],ad[s[j]-'a']),dp[j][j+i-2]+min(de[s[j+i-1]-'a'],ad[s[j+i-1]-'a']));
			if(s[j]==s[j+i-1])
				dp[j][j+i-1]=min(dp[j][j+i-1],dp[j+1][j+i-2]);
		}
	}
	printf("%d",dp[1][m]);
	return 0;
}
posted @ 2022-06-02 18:01  灰鲭鲨  阅读(29)  评论(0编辑  收藏  举报