Packet Tracer 5.0实验(二) 交换机的Telnet远程登录设置
一、实验目标
掌握采用telnet方式配置交换机的方法
二、技术原理
- 配置交换机的管理IP地址(计算机的IP地址与交换机管理IP地址在同一网段);
- 为telnet用户配置用户名和登录口令:
Switch(config)#enble password xxxx //设置进入特权模式的密码;
Switch(config-line)#password xxxx //可以设置通过console端口连接设备及telnet远程登录时所需要的密码。
Switch(config)#line console 0
Switch(config-line)#password xxxx //设置通过console端口连接设备的密码
Switch(config-line)#login
Switch(config)#line vty 0 4
Switch(config-line)#password xxxx //设置telnet远程登录密码
Switch(config-line)#login
三、实验步骤
实验拓扑
Switch>en
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
1、配置交换机的管理IP地址
Switch(config)#interface vlan 1 //默认情况下交换机所有端口都处于 vlan 1 当中
Switch(config-if)#ip address 192.168.1.1 255.255.255.0 //配置交换机管理IP地址
Switch(config-if)#no shutdown //开启Interface Vlan1
%LINK-5-CHANGED: Interface Vlan1, changed state to up
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Switch(config-if)#exit
2、设置进入特权模式的密码
Switch(config)#enable password 123456 //设置进入特权模式的密码
Switch(config)#line console ?
<0-0> First Line number
3、设置通过console端口连接设备的密码
Switch(config)#line console 0
Switch(config-line)#password asdf //设置通过console端口连接设备的密码
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#line vty ?
<0-15> First Line number
4、设置telnet远程登录密码
Switch(config)#line vty 0 4
Switch(config-line)#password abc123 //设置telnet远程登录密码
Switch(config-line)#login
Switch(config-line)#end
Switch#
%SYS-5-CONFIG_I: Configured from console by console
5、查看配置情况
Switch#show running-config
Building configuration...
Current configuration : 1064 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable password 123456
!
!
!
interface FastEthernet0/1
!
......
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
!
line con 0
password asdf
login
!
line vty 0 4
password abc123
login
line vty 5 15
login
!
!
end
Switch#
四、验证
1、验证通过console端口连接设备的密码
Press RETURN to get started.
User Access Verification
Password: //这里输入asdf
Switch>
2、验证进入特权模式的密码
Switch>en
Password: //这里输入123456
Switch#
3、验证telnet远程登录密码
a. 给PC机设置IP地址
b. 打开Command Prompt
Packet Tracer PC Command Line 1.0
PC>ipconfig
IP Address......................: 192.168.1.2
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.1.1
PC>ping 192.168.1.1
Pinging 192.168.1.1 with 32 bytes of data:
Request timed out.
Reply from 192.168.1.1: bytes=32 time=32ms TTL=255
Reply from 192.168.1.1: bytes=32 time=32ms TTL=255
Reply from 192.168.1.1: bytes=32 time=31ms TTL=255
Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 31ms, Maximum = 32ms, Average = 31ms
PC>telnet 192.168.1.1 //远程登录
Trying 192.168.1.1 ...Open
User Access Verification
Password: //vty密码
Switch>en
Password: //enable密码
Switch#show running-config
Building configuration...
Current configuration : 1063 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable password 123456
!
!
!
interface FastEthernet0/1
!
......
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
!
line con 0
password asdf
login
!
line vty 0 4
password abc123
login
line vty 5 15
login
!
!
end
Switch#
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· winform 绘制太阳,地球,月球 运作规律
· AI与.NET技术实操系列(五):向量存储与相似性搜索在 .NET 中的实现
· 超详细:普通电脑也行Windows部署deepseek R1训练数据并当服务器共享给他人
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)