数字配对(二分)



description

给出一组数, 验证这些数中是否有两个数的和为S

input

多组数据,每组数据两行,第一行是两个整数,n(n <= 100,000)和S(0 <= S < 2^32)。
第二行将有n个整数a1, a2, ..., an(0 <= ai < 2^32, 1 <= i <= n),数字之间用空格隔开。

output

每组数据输出一行,仅一个数字,代表有多少不同的有序数字对(ai, aj),使得ai + aj == S。

sample_input

5 4
1 2 3 4 5
6 6
3 3 3 3 3 2

sample_output

3
1

hint

<p>样例一:(1,3)(2,2)(3,1)样例二:(3,3)</p><p><br /></p><p>此题主要是二分的运用,恰当的运用才能更好地去解答这一题,此题我的思路就是从大到小搜索,不过最大值得借助upper_bound函数先求出来,在一个个遍历,每次遍历时再去运用二分,具体查找,特别注意是可能会出现相同数字,所以遍历过程中得一一排除掉,不过,最初的排序可别忘喽!一下附上代码仅供参考:</p><p>
#include <iostream>
#include<stdio h="">
#include<algorithm>
#include<string h="">
using namespace std;
int a[100100];
int er(int n[],int a,int b,int x)
{
    int low=a,high=b,mid,flag=0;
    while(low<=high)
    {
        mid=(low+high)/2;
        if(n[mid]==x)
        {
            flag=1;
            break;
        }else if(n[mid]>x)
        high=mid-1;
        else
            low=mid+1;
    }
    if(flag==0)
        return -1;
    else return 0;
}
int main()
{
    int n,s;
    while(scanf("%d%d",&n,&s)!=EOF)
    {
        memset(a,0,sizeof(a));
        for(int i=0;i<n i="" scanf="" d="" a="" i="" sort="" a="" a="" n="" int="" up="upper_bound(a,a+n,s)-a,k=0;" for="" int="" i="up-1;i">=0;i--)
        {
            if(a[i]==a[i-1]&&i!=0)
                continue;
            if(er(a,0,up-1,s-a[i])!=-1)
                k++;
        }cout<<k<<endl;
    }
    return 0;
}
</n></string></algorithm></stdio></iostream>
<br /></p>
posted @ 2015-02-16 23:01  martinue  阅读(271)  评论(0编辑  收藏  举报