nefu1037回文子序列数(区间dp)

description

给定字符串,求它的回文子序列个数。回文子序列反转字符顺序后仍然与原序列相同。


例如字符串aba中,回文子序列为"a", "a", "aa", "b", "aba",共5个。内容相同位置不同的子序列算不同的子序列。

input

第一行一个整数T,表示数据组数。之后是T组数据,每组数据为一行字符串。

output

对于每组数据输出一行,格式为"Case #X: Y",X代表数据编号(从1开始),Y为答案。答案对100007取模。

sample_input

5
aba
abcbaddabcba
12111112351121
ccccccc
fdadfa

sample_output

Case #1: 5
Case #2: 277
Case #3: 1333
Case #4: 127
Case #5: 17

区间dp基础题:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int dp[1010][1010];
char str[1010];
int len;
void solve(int s,int e)
{
    if(s==e)
    {
        dp[s][e]=1;
        return ;
    }
    if(str[e]==str[s])
      dp[s][e]=dp[s][e-1]+dp[s+1][e]+1;
    else dp[s][e]=dp[s][e-1]+dp[s+1][e]-dp[s+1][e-1];
    dp[s][e]+=100007;
    dp[s][e]%=100007;
}
int main()
{
    int t,T=1;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%s",str);
        len=strlen(str);
        for(int i=0;i<len;i++)
          for(int j=i;j>=0;j--)
            solve(j,i);
        printf("Case #%d: %d\n",T++,dp[0][len-1]);
    }
    return 0;
}


posted @ 2015-05-04 20:53  martinue  阅读(179)  评论(0编辑  收藏  举报