hdu4313(图,和最小生成树类似)

Description

Machines have once again attacked the kingdom of Xions. The kingdom of Xions has N cities and N-1 bidirectional roads. The road network is such that there is a 
unique path between any pair of cities. 

Morpheus has the news that K Machines are planning to destroy the whole kingdom. These Machines are initially living in K different cities of the kingdom and 
anytime from now they can plan and launch an attack. So he has asked Neo to destroy some of the roads to disrupt the connection among Machines. i.e after destroying those roads there should not be any path between any two Machines. 

Since the attack can be at any time from now, Neo has to do this task as fast as possible. Each road in the kingdom takes certain time to get destroyed and they 
can be destroyed only one at a time. 

You need to write a program that tells Neo the minimum amount of time he will require to disrupt the connection among machines. 
 

Input

The first line is an integer T represents there are T test cases. (0<T <=10) 
For each test case the first line input contains two, space-separated integers, N and K. Cities are numbered 0 to N-1. Then follow N-1 lines, each containing three, space-separated integers, x y z, which means there is a bidirectional road connecting city x and city y, and to destroy this road it takes z units of time.Then follow K lines each containing an integer. The ith integer is the id of city in which ith Machine is currently located. 
2 <= N <= 100,000 
2 <= K <= N 
1 <= time to destroy a road <= 1000,000 
 

Output

For each test case print the minimum time required to disrupt the connection among Machines.
 

Sample Input

1 5 3 2 1 8 1 0 5 2 4 5 1 3 4 2 4 0
 

Sample Output

10

Hint

 Neo can destroy the road connecting city 2 and city 4 of weight 5 , and the road connecting city 0 and city 1 of weight 5. As only one road can be destroyed at a time, the total minimum time taken is 10 units of time. After destroying these roads none of the Machines can reach other Machine via any path. 

关键在于排序的时候要把权值从大到小排列!!!


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
const int N=100010;
int f[N];
struct data
{
    int a,b;ll w;
}tu[N];
bool z[N];

bool cmp(data a,data b)
{
    return a.w>b.w;
}

int fa(int x)
{
    if(x!=f[x])
        return f[x]=fa(f[x]);
    return f[x];
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(z,0,sizeof(z));
        int n,k;
        cin>>n>>k;
        for(int i=0;i<n-1;i++)
        {
            f[i]=i;
            scanf("%d%d%I64d",&tu[i].a,&tu[i].b,&tu[i].w);
        }
        f[n-1]=n-1;
        while(k--)
        {
            int tem;
            scanf("%d",&tem);
            z[tem]=1;
        }
        sort(tu,tu+n-1,cmp);
        ll ans=0;
        for(int i=0;i<n-1;i++)
        {
            int x=fa(tu[i].a),y=fa(tu[i].b);
            //cout<<x<<' '<<y<<endl;
            if(z[x]&&z[y])
            {
               ans+=tu[i].w;//cout<<ans<<endl;
               //f[x]=y;
            }else if(z[x])
            {
                f[y]=x;
            }
            else
            f[x]=y;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


posted @ 2016-03-19 17:02  martinue  阅读(200)  评论(0编辑  收藏  举报