poj3278

题目名称:Catch That Cow

题目链接:http://poj.org/problem?id=3278


Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题意:一个农民追牛,每次可以走-1或1步和走2*x步,问追上的最短时间


思路:

1. X往左走当X小于0的时候,2*X不可能大于0了,所以X-1的极限是X-1 >= 0。
2. X往右走当X大于K的时候,不管是2*X还是X-1只会增加到达K的步数,所以X+1的极限是X+1 <= k。
3. 当X>K的时候,2*X也只会增加X到达点K的步数,所以2*X的极限是X<K。


代码如下:

 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct Node
{
    int x,sum;
};
Node tmp,now;
int n,k;
bool vis[1000005];
queue<Node> q;
void bfs()
{
    while(!q.empty())
        q.pop();
    q.push(tmp);
    while(!q.empty())
    {
        Node now=q.front();
        q.pop();
        if(now.x==k)
        {
            printf("%d\n",now.sum);
            return;
        }
        if(now.x-1>=0&&!vis[now.x-1])
        {
            vis[now.x-1]=true;
            tmp.x=now.x-1;
            tmp.sum=now.sum+1;
            q.push(tmp);
        }
        if(now.x+1<=k&&!vis[now.x+1])
        {
            vis[now.x+1]=true;
            tmp.x=now.x+1;
            tmp.sum=now.sum+1;
            q.push(tmp);
        }
        if(now.x<=k&&now.x*2<=100000&&!vis[now.x*2])
        {
            vis[now.x*2]=true;
            tmp.x=now.x*2;
            tmp.sum=now.sum+1;
            q.push(tmp);
        }
    }

}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(vis,false,sizeof(vis));
        tmp.x=n;
        tmp.sum=0;
        bfs();
    }
    return 0;
}

 

 

 

posted @ 2015-07-17 20:33  maplefighting  阅读(137)  评论(0编辑  收藏  举报