poj3279

题目名称:Fliptile

题目链接:http://poj.org/problem?id=3279


Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0


题意:给一个M*N的矩阵,每次牛翻转(x,y),它的上下左右以及本身就会0变1,1变0,问把矩阵变成全0的,最小需要点击多少步。


思路:显然可以看出,当第一行确定时,因为第二行要保证第一行都为0所以下面都是确定的,所以我们只要枚举第一行的所有情况


代码如下:

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
const int INF=0x7ffffff;
int m,n;//b数组记录变换的位置,tmz记录变换时的情况,tmb记录最佳的情况
int a[20][20],b[20][20],tmz[20][20],tmb[20][20];
int dir[4][2]={-1,0,1,0,0,1,0,-1};
bool ok;  //ok记录是否存在
void moving(int x,int y)
{
    tmz[x][y]=tmz[x][y]^1;
    for(int i=0;i<4;i++)
    {
        int nx=x+dir[i][0];
        int ny=y+dir[i][1];
        if(nx<0||ny<0||nx>=m||ny>=n) continue;
        tmz[nx][ny]=tmz[nx][ny]^1;
    }
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        memset(tmb,0,sizeof(tmb));
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            {
                scanf("%d",&a[i][j]);
            }
        int ans=INF;
        ok=false;
        for(int i=0;i<(1<<(n+1));i++)
        {
            memcpy(tmz,a,sizeof(a));
            memset(b,0,sizeof(b));
            int sum=0;
            for(int j=0;j<n;j++)  //用二进制表示第一行各种情况
            {
                int tmp=(i>>j)&1;
                b[0][n-j-1]=tmp;
                if(tmp==1)
                {
                    moving(0,n-j-1);
                    sum++;
                }
            }
            for(int j=1;j<m;j++)
            {
                if(sum>=ans) break;
                for(int k=n-1;k>=0;k--)
                {
                    if(tmz[j-1][k]==1)
                    {
                        moving(j,k);
                        b[j][k]=1;
                        sum++;
                        if(sum>=ans) break;
                    }
                }
            }
            if(sum>=ans) continue;
            bool okj=true;
            for(int j=0;j<n;j++)
            {
                if(tmz[m-1][j]==1)
                {
                    okj=false;
                    break;
                }
            }
            if(okj)
            {
                if(sum<ans)
                {
                    ans=sum;
                    memcpy(tmb,b,sizeof(b));
                }
                ok=true;
            }
        }
        if(ok)
        {
            for(int i=0;i<m;i++)
            {
                printf("%d",tmb[i][0]);
                for(int j=1;j<n;j++)
                    printf(" %d",tmb[i][j]);
                printf("\n");
            }
        }
        else
            printf("IMPOSSIBLE\n");
    }
    return 0;
}

 

 

 

posted @ 2015-07-17 20:55  maplefighting  阅读(141)  评论(0编辑  收藏  举报