hdu1241

题目名称:Oil Deposits

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1241

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

Sample Output
0 1 2 2

题意:题目说的是在一个矩阵里,有些格子是矿井,有些不是,相邻(上、下、左、右、左上、右上、左下、右下)的格子如果也是矿井,那么他们属于同一个矿井,问总共有多少个矿井。


思路:很明显dfs。。


代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
char a[105][105];
int sum=0;
int dir[8][2]={1,0,-1,0,0,1,0,-1,1,1,-1,1,-1,-1,1,-1};
int m,n;
void dfs(int z,int b)
{
    a[z][b]='*';
    for(int i=0;i<8;i++)
    {
        int x=z+dir[i][0];
        int y=b+dir[i][1];
        if(x>=0&&y>=0&&x<n&&y<m)
            if(a[x][y]=='@')
            {
                dfs(x,y);
            }
    }
}
int main()
{
    while(scanf("%d%d%*c",&n,&m)!=EOF)
    {
        if(m==0) break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                scanf("%c",&a[i][j]);
            }
            getchar();
        }
        sum=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(a[i][j]=='@')
                {
                    sum++;
                    dfs(i,j);
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


posted @ 2015-07-22 16:46  maplefighting  阅读(127)  评论(0编辑  收藏  举报