ZOJ Problem Set–1858 Soundex

Time Limit: 2 Seconds      Memory Limit: 65536 KB


Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding.
Soundex coding involves translating each word into a series of digits in which each digit represents a letter:

1 represents B, F, P, or V
2 represents C, G, J, K, Q, S, X, or Z
3 represents D or T
4 represents L
5 represents M or N
6 represents R

The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with the same Soundex coding are considered equivalent.

Input
Each line of input contains a single word, all upper case, less than 20 letters long.

Output

For each line of input, produce a line of output giving the Soundex code.

Sample Input
KHAWN
PFISTER
BOBBY

Sample Output
25
1236
11


Source: University of Waterloo Local Contest 1999.09.25

#include<iostream>
#include<string>
using namespace std;
int main(void)
{
  string uword;
  while(cin>>uword)
  {
    int preI = 0, crtI = 0;
    for(int i = 0; i < uword.length(); i++)
    {
      switch(uword[i])
      {
      case 'B':case 'F':case 'P':case 'V':
        crtI = 1;
        if(preI != crtI)
        {
          cout<<crtI;
          preI = crtI;
        }
        break;
      case 'C':case 'G':case 'J':case 'K':case 'Q':case 'S':case 'X':case 'Z':
        crtI = 2;
        if(preI != crtI)
        {
          cout<<crtI;
          preI = crtI;
        }
        break;
      case 'D':case 'T':
        crtI = 3;
        if(preI != crtI)
        {
          cout<<crtI;
          preI = crtI;
        }
        break;
      case 'L':
        crtI = 4;
        if(preI != crtI)
        {
          cout<<crtI;
          preI = crtI;
        }
        break;
      case 'M':case 'N':
        crtI = 5;
        if(preI != crtI)
        {
          cout<<crtI;
          preI = crtI;
        }
        break;
      case 'R':
        crtI = 6;
        if(preI != crtI)
        {
          cout<<crtI;
          preI = crtI;
        }
        break;
      default:
        preI = 0;
        break;
      }
    }
    cout<<endl;
  }
  return 0;
}
posted @ 2012-05-07 17:32  Gavin Lipeng Ma  阅读(388)  评论(0编辑  收藏  举报