ZOJ Problem Set–1526 Big Number

Time Limit: 10 Seconds      Memory Limit: 32768 KB


In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= n <= 10^7 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19


Source: Asia 2002, Dhaka (Bengal)

解此题的时候有一个疑惑:floor(double) 和 (int)double 有什么区别?前者取不大于指定参数的最大整数,后者抛弃了小数部分,两者不相等吗?

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
  int cases, n;cin>>cases;
  while(cases-- && cin>>n)
  {
    double digit = 0;
    for(int i = 1; i <= n; i++)
      digit += log(i*1.0);
    cout<<(int)(digit/log(10.0))+1<<endl;
  }
}//AC

 

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
  int cases, n;cin>>cases;
  while(cases-- && cin>>n)
  {
    double digit = 0;
    for(int i = 1; i <= n; i++)
      digit += log(i*1.0);
    cout<<floor(digit/log(10.0))+1<<endl;
  }
}//WA
posted @ 2012-03-31 17:34  Gavin Lipeng Ma  阅读(206)  评论(0编辑  收藏  举报