POJ 2385 Apple Catching

Apple Catching
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6350   Accepted: 3077

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6
题目大意:一共有 2 棵苹果树,一头奶牛站在其中一棵苹果树下等待苹果落下,由于任意一个时刻只能站在一棵树下,它从一棵树移动到另外一棵树的时间不计,奶牛不愿意太频繁移动,现在给定苹果的下落次序和最大移动次数,问奶牛最多可以抓住几个苹果。
#include <stdio.h>
#include <iostream>
using namespace std;

int num[1005];
int dp[1005][35][2];

int main()
{

    int n, times, maxsum = -1;
    scanf("%d%d", &n, &times);
    for (int i = 1; i <= n; i++)
    {
        scanf("%d", &num[i]);
    }
    for (int i = 1; i <= n; i++)
    {
        dp[i][0][0] = dp[i - 1][0][0] + (num[i] == 1);
        dp[i][0][1] = dp[i - 1][0][1] + (num[i] == 2);
        for (int j = 1; j <= times; j++)
        {
            dp[i][j][0] = max(dp[i - 1][j - 1][1], dp[i - 1][j][0]) + (num[i] == 1);
            dp[i][j][1] = max(dp[i - 1][j - 1][0], dp[i - 1][j][1]) + (num[i] == 2);
            maxsum = max(maxsum, max(dp[i][j][0], dp[i][j][1]));
        }
    }
    printf("%d\n", maxsum);
    return 0;
}

 

posted on 2013-08-03 14:57  lzm风雨无阻  阅读(687)  评论(0编辑  收藏  举报

导航