POJ 1163 The Triangle

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 33476   Accepted: 19865

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

int maze[105][105];
int dp[105][105];

int main()
{
    int n;
    scanf("%d", &n);
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= i; j++)
        {
            scanf("%d", &maze[i][j]);
        }
    }
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= i; j++)
        {
            dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - 1]) + maze[i][j];
        }
    }
    int Max = -10000000;
    for (int i = 1; i <= n; i++)
    {
        Max = max(Max, dp[n][i]);    
    }
    printf("%d\n", Max);
    return 0;
}

 

posted on 2013-07-22 22:02  lzm风雨无阻  阅读(306)  评论(0编辑  收藏  举报

导航