POJ 2386 Lake Counting

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15978   Accepted: 8079

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
#include <stdio.h>
#include <iostream>
using namespace std;

char Map[105][105];
int m, n;

void DFS(int x, int y)
{
    if (x >= 0 && x < m && y >= 0 && y < n && Map[x][y] == 'W')
    {
        Map[x][y] = '.';
        DFS(x + 1, y);
        DFS(x, y + 1);
        DFS(x - 1, y);
        DFS(x, y - 1);
        DFS(x + 1, y - 1);
        DFS(x - 1, y + 1);
        DFS(x - 1, y - 1);
        DFS(x + 1, y + 1);
    }
    
}


int main()
{
    int sum = 0;
    scanf("%d%d", &m, &n);
    for (int i = 0; i < m; i++)
    {
        scanf("%s", Map[i]);
    }
    for (int i = 0; i < m; i++)
    {
        for (int j = 0; j < n; j++)
        {
            if (Map[i][j] == 'W')
            {
                sum++;
                DFS(i, j);
            }
        }
    }
    printf("%d\n", sum);
    return 0;
}

 

posted on 2013-07-21 21:50  lzm风雨无阻  阅读(233)  评论(0编辑  收藏  举报

导航