POJ 1745 Divisibility

Divisibility
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9476   Accepted: 3300

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible
#include <stdio.h>
#include <iostream>
using namespace std;

int dp[10001][101] = {0};
int num[10001] = {0};

int main()
{
    int k, n;
    scanf("%d%d", &n, &k);
    for (int i = 0; i < n; i++)
    {
        scanf("%d", &num[i]);
        if (num[i] < 0)
        {
            num[i] *= -1;
        }
        num[i] = num[i] % k;
    }
    dp[0][num[0]] = 1;
    for (int i = 1; i < n; i++)
    {
        for (int j = 0; j <= k; j++)
        {
            if (dp[i - 1][j])
            {
                dp[i][(j + num[i]) % k] = 1;
                dp[i][(k + j - num[i]) % k] = 1;
            }
        }
    }
    if(dp[n-1][0])  
    {
        printf("Divisible\n"); 
    }
    else  
    {
        printf("Not divisible\n");  
    }
    return 0;
}

 

posted on 2013-07-20 14:47  lzm风雨无阻  阅读(343)  评论(0编辑  收藏  举报

导航