HDU 2896 病毒侵袭

病毒侵袭

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7449    Accepted Submission(s): 1958


Problem Description
当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 

 

Input
第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 

 

Output
依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 

 

Sample Input
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

 

Sample Output
web 1: 1 2 3 total: 1
题目大意:给出一组病毒序列,然后给出一组网站信息,对于每个网站信息,问有多少病毒序列出现过,按编号从小到大列出其编号。
解题方法:AC自动机。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <queue>
#include <vector>
using namespace std;

#define  KIND    128
#define  MAXLEN  10010

typedef struct node
{
    int id;
    node *fail;
    node *next[KIND];
    node()
    {
        id = 0;
        fail = NULL;
        memset(next, NULL, sizeof(next));
    }
}TreeNode;

queue<TreeNode*> Queue;

void Insert(TreeNode *pRoot, char str[], int id)
{
    int nLen = strlen(str);
    TreeNode *p = pRoot;
    for (int i = 0; i < nLen; i++)
    {
        int index = str[i];
        if (p->next[index] == NULL)
        {
            p->next[index] = new TreeNode;
        }
        p = p->next[index];
    }
    p->id = id;
}

void BuildAC(TreeNode *pRoot)
{
    Queue.push(pRoot);
    while(!Queue.empty())
    {
        TreeNode *p = Queue.front();
        Queue.pop();
        for (int i = 0; i < KIND; i++)
        {
            if (p->next[i] != NULL)
            {
                if (p == pRoot)
                {
                    p->next[i]->fail = pRoot;
                }
                else
                {
                    TreeNode *temp = p->fail;
                    while(temp != NULL)
                    {
                        if (temp->next[i] != NULL)
                        {
                            p->next[i]->fail = temp->next[i];
                            break;
                        }
                        temp = temp->fail;
                    }
                    if (temp == NULL)
                    {
                        p->next[i]->fail = pRoot;
                    }
                }
                Queue.push(p->next[i]);
            }
        }
    }
}


bool Query(TreeNode *pRoot, char str[], int nCount)
{
    vector<int> vec;
    int nLen = strlen(str);
    TreeNode *p = pRoot;
    bool flag = false;
    for (int i = 0; i < nLen; i++)
    {
        int index = str[i];
        while(p != pRoot && p->next[index] == NULL)
        {
            p = p->fail;
        }
        p = p->next[index];
        if (p == NULL)
        {
            p = pRoot;
        }
        TreeNode *temp = p;
        while(temp != pRoot && temp->id != 0)
        {
            if (temp->id > 0)
            {
                flag = true;
                vec.push_back(temp->id);
            }
            temp = temp->fail;
        }
    }
    if (flag)
    {
        sort(vec.begin(), vec.end());
        printf("web %d:", nCount);
        printf(" %d", vec[0]);
        for (int i = 1; i < vec.size(); i++)
        {
            if (vec[i - 1] != vec[i])
            {
                printf(" %d", vec[i]);
            }
        }
        printf("\n");
    }
    return flag;
}

int main()
{
    int n;
    scanf("%d", &n);
    int nTotal = 0;
    char str[205], str1[10005];
    TreeNode *pRoot = new TreeNode;
    for (int i = 0; i < n; i++)
    {
        scanf("%s", str);
        Insert(pRoot, str, i + 1);
    }
    BuildAC(pRoot);
    scanf("%d", &n);
    for (int i = 0; i < n; i++)
    {
        scanf("%s", str1);
        if (Query(pRoot, str1, i + 1))
        {
            ++nTotal;
        }
    }
    printf("total: %d\n", nTotal);
    return 0;
}

 

posted on 2013-07-10 20:38  lzm风雨无阻  阅读(217)  评论(0编辑  收藏  举报

导航