POJ 1035 Spell checker

Spell checker

Time Limit: 2000MS
Memory Limit: 65536K

Total Submissions: 12797
Accepted: 4719

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
这道题我用STL做了一下,但是WA,估计是POJ和STL不兼容。
STL代码:

#include <iostream>
#include <string>
#include <vector>
#include <cstdlib>
using namespace std;

string current;
vector <string> str;
int Len_cur,Len_str,flag;

//int Cmp(void const *a,void const *b)
//{
//    return strcmp((char*)a,(char*)b);
//}

void Replace(string temp)
{
    int i,Count,Temp_len;
    Count=0;
    Temp_len=temp.length();
    for(i=0;i<Temp_len;i++)
    {
        if(temp[i]!=current[i])
        {
            Count++;
        }
    }
    if(Count==1)
    {
        cout<<" "<<temp;
        return ;
    }
}

void Insert(string temp)
{
    string Temp;
    int Len_Temp,i;
    Temp=temp;
    Len_Temp=current.length();
    for(i=0;i<Len_Temp;i++)
    {
        if(current[i] == Temp[i] && i==Len_Temp-2)
        {
            cout<<" "<<temp;
            return ;
        }
        if(Temp[i]!=current[i])
        {
            Temp.insert(i,1,current[i]);
            if(current==Temp)
            {
                cout<<" "<<temp;
                return ;
            }
        }
    }
}

void Delete(string temp)
{
    string Temp;
    int Len_temp,i;
    Temp=temp;
    Len_temp=Temp.length();
    for(i=0;i<Len_temp;i++)
    {
        if(current[i] == Temp[i] && i==Len_temp-2)
        {
            cout<<" "<<temp;
            return ;
        }
        if(current[i] != Temp[i])
        {
            Temp.erase(i,1);
            if(Temp==current)
            {
                cout<<" "<<temp;
            }
            return ;
        }
    }
}

int main()
{
    int i,j;
    while(1)
    {
        cin>>current;
        if(current=="#")
        {
            break;
        }
        str.push_back(current);
    }
    //qsort(&str[0],str.size(),sizeof(str[0]),Cmp);
    while(1)
    {
        cin>>current;
        if(current=="#")
        {
            break;
        }
        flag=0;
        for(i=0;i<str.size();i++)
        {
            if(current==str[i])
            {
                cout<<current<<" is is correct"<<endl;
                flag=1;
                break;
            }
        }
        if(!flag)
        {
            cout<<current<<" :";
            Len_cur=current.length();
            for(i=0;i<str.size();i++)
            {
                Len_str=str[i].length();
                if(Len_cur==Len_str)
                {
                    Replace(str[i]);
                }
                if(Len_str==Len_cur+1)
                {
                    Delete(str[i]);
                }
                else
                    if(Len_str==Len_cur-1)
                    {
                        Insert(str[i]);
                    }
            }
            cout<<endl;
        }
    }
    return 0;
}

AC代码,复制了别人的代码,觉得思想已经明白,没必要再去写代码了,就把别人的代码贴上来。

#include<stdio.h> 
#include<string.h> 
char word[10010][20],s[20]; 
int ha(int i,char *p) 

    int j,k; 
    int l=strlen(word[i]),len=strlen(s); 
    int cha=l-len; 
    if(cha<0) 
        cha=-cha; 
    if(cha>1)//长度差大于一的无法修改 
        return 0; 
    if(l==len) 
    { 
        int bu=0; 
        for(j=0;j<l;j++) 
            if(word[i][j]!=s[j]) 
                bu++; 
        if(bu==1)//长度相等时只能有一个字母不同 
            return 1; 
        else return 0; 
    } 
    if(l<len) 
    { 
        int bu=0; 
        for(j=0,k=0;j<=l&&k<=len;) 
        { 
            if(word[i][j]==s[k]) 
            { 
                j++; 
                k++; 
            } 
            else 
            { 
                bu++; 
                k++;//出错单词比词典词大一时,碰到不同字母,出错单词跳过去 
            } 
        } 
        if(bu==1)//只能跳过一个 
            return 1; 
        else return 0; 
    } 
    if(l>len) 
    { 
        int bu=0; 
        for(j=0,k=0;j<=l&&k<=len;) 
        { 
            if(word[i][j]==s[k]) 
            { 
                j++; 
                k++; 
            } 
            else 
            { 
                bu++; 
                j++;//出错单词比词典词小一时,碰到不同字母,词典词跳过去 
            } 
        } 
        if(bu==1)//只能跳过一个 
            return 1; 
        else return 0; 
    } 

int main() 

    int i=0,n; 
    while(gets(word[i++])) 
    { 
        if(word[i-1][0]=='#') 
            break; 
    } 
    i--; 
    n=i; 
    while(gets(s)) 
    { 
        if(s[0]=='#') 
            break; 
        for(i=0;i<n;i++) 
            if(strcmp(word[i],s)==0) 
            { 
                printf("%s is correct\n",word[i]); 
                break; 
            } 
        if(i<n) 
            continue; 
        printf("%s:",s); 
        for(i=0;i<n;i++) 
        { 
            if(ha(i,s)) 
            { 
                printf(" %s",word[i]); 
            } 
        } 
        printf("\n"); 
    } 
    return 0; 

posted on 2012-03-03 00:12  lzm风雨无阻  阅读(313)  评论(0编辑  收藏  举报

导航