USACO Superprime Rib

Butchering Farmer John's cows always yields the best prime rib. You can tell prime ribs by looking at the digits lovingly stamped across them, one by one, by FJ and the USDA. Farmer John ensures that a purchaser of his prime ribs gets really prime ribs because when sliced from the right, the numbers on the ribs continue to stay prime right down to the last rib, e.g.:

     7  3  3  1

The set of ribs denoted by 7331 is prime; the three ribs 733 are prime; the two ribs 73 are prime, and, of course, the last rib, 7, is prime. The number 7331 is called a superprime of length 4.

Write a program that accepts a number N 1 <=N<=8 of ribs and prints all the superprimes of that length.

The number 1 (by itself) is not a prime number.

Input

A single line with the number N.

Output

The superprime ribs of length N, printed in ascending order one per line.

Sample Input

4

Sample Output

2333
2339
2393
2399
2939
3119
3137
3733
3739
3793
3797
5939
7193
7331
7333
7393

#include <iostream>
using namespace std;

int Head_Num[5]={2,3,5,7},Tail_Num[5]={1,3,7,9};
int n;

int check(int x)
{
    int i,j;
    if(x==2)
    {
        return 1;
    }
    if(x%2==0)
    {
        return 0;
    }
    for(i=2;i*i<=x;i++)
    {
        if(x%i==0)
        {
            return 0;
        }
    }
    return 1;
}

void DFS(int Num,int N)
{
    int i,j;

    if(N==n)
    {
        if(check(Num))
        {
            cout<<Num<<endl;
        }
        return ;
    }
    for(j=0;j<4;j++)
    {
        if(check(Num*10+Tail_Num[j]))
        {
            DFS(Num*10+Tail_Num[j],N+1);
        }
    }
}

int main()
{
    cin>>n;
    DFS(2,1);
    DFS(3,1);
    DFS(5,1);
    DFS(7,1);
    return 0;
}

posted on 2012-02-25 18:20  lzm风雨无阻  阅读(405)  评论(0编辑  收藏  举报

导航