HDU 2606 Bone Collector

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

#include <iostream>
#include <cstring>
using namespace std;

int dp[1005],v[1005],w[1005];
int N,V;
void DP()
{
    int i,j;
    for(i=0;i<N;i++)
    {
        for(j=V;j>=w[i];j--)
        {
            dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        }
    }
    cout<<dp[V]<<endl;
}

int main()
{
    int i;
    int T;
    cin>>T;
    while(T--)
    {
        cin>>N>>V;
        for(i=0;i<N;i++)
        {
            cin>>v[i];
        }
        for(i=0;i<N;i++)
        {
            cin>>w[i];
        }
        memset(dp,0,sizeof(dp));
        DP();
    }
    return 0;
}

posted on 2012-02-23 13:38  lzm风雨无阻  阅读(289)  评论(0编辑  收藏  举报

导航