HDU 1712 ACboy needs your help

Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0
Sample Output
3
4
6
分析:本题为分组背包,每组只能选一个。
代码如下:

#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    int i,j,k;
    int dp[105],a[105][105];
    int m,n;
    while(cin>>n>>m,n,m)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                cin>>a[i][j];
            }
        }
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
        {
            for(j=m;j>=0;j--)
            {
                for(k=1;k<=j;k++)
                {
                    dp[j]=max(dp[j],dp[j-k]+a[i][k]);
                }
            }
        }
        cout<<dp[m]<<endl;
    }
    return 0;
}

posted on 2012-02-22 20:52  lzm风雨无阻  阅读(290)  评论(0编辑  收藏  举报

导航