HDU 1085 Holding Bin-Laden Captive

Problem Description

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”

Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input

Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output

Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input
1 1 3
0 0 0
Sample Output
4

分析:此题可以用多重背包做,但是要先用二进制优化,转化为01背包,也可以用母函数,分别列出代码,。

多重背包:

#include <iostream>
using namespace std;

int main()
{
    int n1,n2,n3;
    int i,j;
    int dp[10000];
    int money[1000];
    int count;
    while(cin>>n1>>n2>>n3,n1,n2,n3)
    {
        count=-1;
        j=1;
        while(1)
        {
            if(n1-j<=0)
            {
                count++;
                money[count]=n1;
                break;
            }
            count++;
            money[count]=j;
            n1-=j;
            j*=2;
        }
        j=1;
        while(1)
        {
            if(n2-j<=0)
            {
                count++;
                money[count]=n2*2;
                break;
            }
            count++;
            money[count]=j*2;
            n2-=j;
            j*=2;
        }
        j=1;
        while(1)
        {
            if(n3-j<=0)
            {
                count++;
                money[count]=n3*5;
                break;
            }
            count++;
            money[count]=j*5;
            n3-=j;
            j*=2;
        }
        for(i=0;i<10000;i++)
        {
            dp[i]=-10000000;
        }
        dp[0]=0;
        for(i=0;i<=count;i++)
        {
            for(j=9999;j>=money[i];j--)
            {
                dp[j]=max(dp[j],dp[j-money[i]]+money[i]);
            }
        }
        for(i=1;i<=9999;i++)
        {
            if(dp[i]<0)
            {
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}

母函数:

#include<iostream>
using namespace std;
int main()
{
    int num_1,num_2,num_5,num,i,j,k;
    int c[8005],temp[8005];
    while(scanf("%d%d%d",&num_1,&num_2,&num_5)!=EOF&&(num_1||num_2||num_5) )
    {
        num=num_1*1+num_2*2+num_5*5;        
        for( i=0;i<=num;i++)
        { //初始化
            c[i]=0;
            temp[i]=0;       
        }  
        //第一个表达式和第二个表达式相乘
        for( i=0;i<=num_1;i++) //用第一个表达式表(即面值为1的硬币)表达所有的面值都只有一种情况
            c[i]=1;      
        for( j=0;j<=num_1*1;j++)
            for( k=0;k<=num_2*2;k+=2)
                temp[j+k]+=c[j];
        for( j=0;j<=num_1*1+num_2*2;j++)
        {//扩大面值范围
            c[j]=temp[j];
            temp[j]=0;
        }
        //第二个表达式和第三个表达式相乘
        for( j=0;j<=num_1*1+num_2*2;j++)
            for( k=0;k<=num_5*5;k+=5)
                temp[j+k]+=c[j];
        for( j=0;j<=num;j++)
        {  //扩充范围
            c[j]=temp[j];
            temp[j]=0;       
        }
        for( i=0;i<=num;i++)  //查找第一个为0的数
            if(c[i]==0)
            {             
                break;           
            }
            printf("%d\n",i);  //不知道是什么原因,这个放在if(c[i]==0) 里面是WA的 ,估计是HDOJ的系统问题
    }
    return 0;
}

posted on 2012-02-21 22:11  lzm风雨无阻  阅读(405)  评论(0编辑  收藏  举报

导航