hdu 1028 Ignatius and the Princess III

Ignatius and the Princess III

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input
4
10
20
Sample Output
5
42
627
总结:这道题可以用背包问题来做,在网上看了一些大牛的代码但是始终不理解,发现可以用母函数来解,临时学了一下母函数也是似懂非懂,下面是我的代码:

#include <iostream>
using namespace std;

int m1[125],m2[125];

int main()
{
    int i,j,k;
    int n;
    for(i=0;i<=121;i++)
    {
        m1[i]=1;
        m2[i]=0;
    }
    for(i=2;i<=121;i++)//总共有n个括号,从第2个起每一个括号都要和前面那一个括号相乘
    {
        for(j=0;j<=121;j++)//j代表最前面这个大括号的项数
        {
            for(k=0;k+j<=121;k+=i)//在大括号后面,x都是以i方递增的
            {
                m2[k+j]+=m1[j];
            }
        }
        for(j=0;j<=121;j++)//算完以后都存在m2里面,所以要把值赋给m1,
        {
            m1[j]=m2[j];
            m2[j]=0;
        }
    }
    while(cin>>n)
    {
        cout<<m1[n]<<endl;
    }
    return 0;
}

下面是别人用动态规划做的:希望哪位大牛来指点一下:

# include <stdio.h>

int dp[130][130] ;

int main ()
{
int i, j, n ;
dp[0][0] = 1 ;
for (i = 1 ; i <= 120 ; i++)
{
for (j = 0 ; j < i ; j++) dp[i][j] = dp[i-1][j] ;
for (j = i ; j <= 120 ; j++)
dp[i][j] = dp[i-1][j] + dp[i][j-i] ;
}
while (~scanf ("%d", &n))
{
printf ("%d\n", dp[n][n]) ;
}
return 0 ;
}

posted on 2012-02-21 13:35  lzm风雨无阻  阅读(157)  评论(0编辑  收藏  举报

导航