HDU OJ Pearls

Pearls

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 6
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family. In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed. No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10 + (100+10)*20 = 2350 Euro.
Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.
Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested, or in a higher quality class, but not in a lower one.

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1 <= c <= 100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

Sample Input
2
2
100 1
100 2
3
1 10
1 11
100 12
Sample Output
330
1344

题目大意是:一个finacial officer  想要把pearls卖出去,卖出去的规则是这样的:

珍珠的数量和价格不一样,高质量的珍珠价格自然比较高,每买一种珍珠还要额外加买了10颗这类的珍珠,但是如果是至少买两种珍珠以上的,可以考虑用高质量的珍珠代替相对低质量的珍珠,外加买了10个高质量的珍珠,就不用再额外的加买10个低质量的珍珠还要加买10个高质量的珍珠,如:买5 个价格为2和买100个价格为3的珍珠,分开买需要花费:(5+10)*2+(100+10)*3=360 ,用高质量的珍珠代替低质量的珍珠需要花费:(5+100+10)*3=345 自然花费比较少

如果用dp[i]表示买前i种珍珠需要花的费用最少,sum[i]表示买到前i种珍珠的数量

高质量的珍珠只可以和前面相对低质量的珍珠进行合并一起购买

有状态转移方程:

dp[i]=min(dp[i],dp[j]+(sum[i]-sum[j]+10)*p[i]) 其中1<=j<=i;

sum[i]-sum[j]:表示第j种珍珠和第i珍珠之间珍珠进行合并一起购买.

代码如下:

#include <iostream>
using namespace std;

int main()
{
    int dp[105];
    int N,n;
    int i,j,k;
    int count;
    int Min,temp;
    int need[105],price[105],sum[105];
    cin>>N;
    while(N--)
    {
        cin>>n;
        memset(dp,0,sizeof(dp));
        memset(sum,0,sizeof(sum));
        for(i=1;i<=n;i++)
        {
            cin>>need[i]>>price[i];
            sum[i]=need[i]+sum[i-1];
            dp[i]=(sum[i]+10)*price[i];
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<i;j++)
            {
                dp[i]=min(dp[i],dp[j]+(sum[i]-sum[j]+10)*price[i]);
            }
        }
        cout<<dp[n]<<endl;
    }
    return 0;
}

posted on 2012-02-19 22:30  lzm风雨无阻  阅读(209)  评论(0编辑  收藏  举报

导航