HDU OJ Constructing Roads In JGShining's Kingdom

Constructing Roads In JGShining's Kingdom

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.
Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.
With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.
Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.
The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.
But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.
For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output

For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.

Sample Input
2
1 2
2 1
3
1 2
2 3
3 1
Sample Output
Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

分析:

这道题实际上就是求第二个组成序列的最长不降子序列,因此可以用一个数组d[len]来放最长不降子序列,再通过二分查找,这样时间复杂度降低为

O(NlogN)!

 

代码如下:

#include <stdio.h>
int city[500005];
int dp[500005];

int binaryseach(int x,int len)
{
    int left,mid,right;
    left=1;
    right=len;
    while(left<=right)
    {
        mid=(right+left)/2;
        if(dp[mid]<x)
        {
            left=mid+1;
        }
        else
        {
            right=mid-1;
        }
    }
    return left;
}

int main()
{
    int i,j;
    int len;
    int r,p;
    int n;
    int casen;
    casen=0;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&r,&p);
            city[r]=p;
        }
        dp[0]=-1000000;
        dp[1]=city[1];
        len=1;
        for(i=2;i<=n;i++)
        {
            j=binaryseach(city[i],len);
            dp[j]=city[i];
            if(j>len)
            {
                len=j;
            }
        }
        if(len==1)
        {
            printf("Case %d:\nMy king, at most 1 road can be built.\n\n",++casen);
        }
        else
        {
            printf("Case %d:\nMy king, at most %d roads can be built.\n\n",++casen,len);
        }
    }
    return 0;
}

posted on 2012-02-15 20:50  lzm风雨无阻  阅读(187)  评论(0编辑  收藏  举报

导航