Binary Numbers

描述

 

Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example
The positions of 1's in the binary representation of 13 are 0, 2, 3.

Task
Write a program which for each data set:
reads a positive integer n,
computes the positions of 1's in the binary representation of n,
writes the result.

 

输入

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

输出

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

样例输入

1
13

样例输出

 0 2 3

code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int n, x;
    cin>>n;
    while(n--){
     cin>>x;
     int num=0;
     bool flag = true;
     while(x){
         if(x&1){
             if(flag){
                cout<<num;
                flag = false;
              }else{
               cout<<" "<<num;
              }
         }
           num++;
           x = x>>1;
      }
      cout<<endl;
    }
 return 0;
}

  

posted @ 2016-09-30 21:32  lzyer  阅读(205)  评论(0编辑  收藏  举报