2112. [NOIP2015普及]求和

★   输入文件:2015sum.in   输出文件:2015sum.out   简单对比

时间限制:1 s   内存限制:256 MB

【题目描述】

 

一条狭长的纸带被均匀划分出了 n 个格子,格子编号从 1 到 n。每个格子上都染了一种 颜色 (用[1,m]当中的一个整数表示),并且写了一个数字 。

定义一种特殊的三元组:(x, y, z),其中 x,y,z 都代表纸带上格子的编号,这里的三元组要求满足以下两个条件:

1.x,y,z都是整数,x<y<z,y-x=z-y

2.colorx = colorz

满足上述条件的三元组的分数规定为(x + z) ∗ ( numberx+numberz )。整个纸带的分数 规定为所有满足条件的三元组的分数的和。这个分数可能会很大,你只要输出整个纸带的分 数除以 10,007 所得的余数即可。

 

【输入格式】

 

第一行是用一个空格隔开的两个正整数n和m,n代表纸带上格子的个数,m代表纸带上颜色的种类数。

第二行有n个用空格隔开的正整数,第i个数字number_i代表纸带上编号为i的格子上面写的数字。

第三行有n个用空格隔开的正整数,第i个数字color_i代表纸带上编号为i的格子染的颜色。

 

【输出格式】

共一行,一个整数,表示所求的纸带分数除以 10,007 所得的余数。

【样例输入1】

6 2	
5 5 3 2 2 2
2 2 1 1 2 1

【样例输出1】

82

【提示】

 

【输入输出样例 1 说明】

 

纸带如题目描述中的图所示。 所有满足条件的三元组为:(1,3, 5), (4, 5, 6)。

所以纸带的分数为(1 + 5) ∗ (5 + 2) + (4 + 6) ∗ (2 + 2) = 42 + 40 = 82。

 

【样例输入2】

15 4
5 10 8 2 2 2 9 9 7 7 5 6 4 2 4
2 2 3 3 4 3 3 2 4 4 4 4 1 1 1

【样例输出2】

1388

【数据说明】

对于全部 10 组数据,1≤n≤100000,1 ≤m≤100000, 1≤colori≤, 1≤numberi≤ 100000。

【来源】

NOIP2015普及组第三题

 

暴力超时:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<algorithm>
#define ll long long

using namespace std;
const int N=100010;
const int mod=10007;

int num[N],col[N];
int n,m;
ll answer;

inline int read()
{
	int x=0;int f=1;char c=getchar();
	while(c<'0'||c>'9'){if(c=='-')f=-1;c=getchar();}
	while(c>='0'&&c<='9')x=x*10+c-'0',c=getchar();
	return x*f;
}

int main()
{
	freopen("2015sum.in","r",stdin);
	freopen("2015sum.out","w",stdout);
	n=read(),m=read();
	for(int i=1;i<=n;i++)num[i]=read();
	for(int i=1;i<=n;i++)col[i]=read();
	for(int i=1;i<n;i++)
		for(int j=i+2;j<=n;j+=2)
			if(col[i]==col[j])
				answer+=((i+j)*(num[i]+num[j]))%mod;
	printf("%lld",answer%mod);
	
	return 0;
}

  

正解    

#include<cstring>  
#include<algorithm>  
#include<cstdio>
#define ll long long  
#define mod 10007  
using namespace std;
ll num[100010],color[100010],n,m; ll cnt[100010][2],nm[100010][2],sumj[100010][2],sum[100010][2],ans;
int main() { freopen("2015sum.in","r",stdin); freopen("2015sum.out","w",stdout); int i,j; scanf("%lld%lld",&n,&m); for(i=1;i<=n;++i) scanf("%lld",&num[i]); for(i=1;i<=n;++i) scanf("%lld",&color[i]); for(i=1;i<=n;++i) { int c=color[i],x=i%2; cnt[c][x]++; if(cnt[c][x]>1) ans+=(nm[c][x]*num[i]%mod+sumj[c][x]+(cnt[c][x]-1)*i*num[i]%mod+i*sum[c][x]%mod)%mod; ans%=mod; nm[c][x]=(nm[c][x]+i)%mod; sumj[c][x]=(sumj[c][x]+i*num[i])%mod; sum[c][x]=(sum[c][x]+num[i])%mod; } ans%=mod; printf("%lld\n",ans); return 0; }

  

前缀和+乱搞:

 

posted @ 2017-07-13 09:50  ioioioioioio  阅读(160)  评论(0编辑  收藏  举报